Routing Statis


Pada suatu jaringan berskala besar atau jaringan kelas enterprise yang terdiri dari banyak lokasi yang tersebar secara remote, maka komunikasi antar site harus dilakukan dengan manajemen protokol routing. Baik routing statis maupung routing dinamis dapat diterapkan pada jaringan tersebut dan didisain sedemikian rupa sehingga menjadi efisien.

Routing statis adalah suatu mekanisme routing yang dilakukan secara manual dengan membuat tabel routing pada setiap perangkat router yang ada. Sedangkan routing dinamis adalah mekanisme routing dimana pertukaran tabel routing antar router yang terdapat pada jaringan dilakukan secara dinamis.

Pada jaringan skala kecil yang terdiri hanya dua atau tiga router saja, kita lebih umum menggunakan routing statis. Routing statis harus dikonfigurasi secara manual dan dipelihara secara manual juga karena tidak dapat melakukan pertukaran informasi tabel routing secara dinamis dengan router-router lainnya.

Routing statis akan berfungsi dengan baik bila tabel routing pada setiap jaringan didalam internetwork sudah dikonfigurasi secara manual oleh administrator jaringan. Setiap host pada pada jaringan harus dikonfigurasi untuk mengarah kepada routing default atau default gateway agar sesuai dengan alamat IP dari interface pada router lokal, router tersebut akan memeriksa tabel routing dan menentukan route yang mana yang akan digunakan untuk meneruskan paket.

Disini kita akan praktek membuat routing statis dengan menggunakan program Cisco Packet Tracert untuk simulasinya. Kita asumsikan program ini sudah terpasang pada komputer dan mari kita mulai belajar membuat routing statis. Berikut adalah topologi jaringan yang akan kita buat:

Perintah dasar menggunakan routing statis:

ip route destination subnet_mask out_going_interface

atau

ip route destination subnet_mask gateway

Contoh:

ip route 192.168.2.0 255.255.255.0 S0
ip route 192.168.2.0 255.255.255.0 192.168.1.2

Konfigurasi IP:

Router Starling
Starling>enable
Starling#configure terminal
Starling#interface Fa0/0
Starling#ip address 192.168.0.1 255.255.255.0
Starling#no shutdown
Starling#exit

Starling#interface S0/1/0
Starling#ip address 192.168.1.1 255.255.255.252
Starling#clockrate 125000
Starling#no shutdown
Starling#^Z
Router Idschool
Idschool>enable
Idschool#configure terminal
Idschool#interface Fa0/0
Idschool#ip address 192.168.2.1 255.255.255.0
Idschool#no shutdown
Idschool#exit

Idschool#interface S0/1/0
Idschool#ip address 192.168.1.2 255.255.255.252
Idschool#clockrate 125000
Idschool#no shutdown
Idschool#exit
Starling#interface S0/1/1
Starling#ip address 192.168.3.1 255.255.255.252
Starling#clockrate 125000
Starling#no shutdown
Starling#^Z
Router Nusatama
Nusatama>enable
Nusatama#configure terminal
Nusatama#interface Fa0/0
Nusatama#ip address 192.168.4.1 255.255.255.0
Nusatama#no shutdown
Nusatama#exit

Nusatama#interface S0/1/0
Nusatama#ip address 192.168.3.2 255.255.255.252
Nusatama#clockrate 125000
Nusatama#no shutdown
Nusatama#^Z

Konfigurasi Routing Statis:

Router Starling
Starling>enable
Starling#configure terminal
Starling#ip route 192.168.2.0 255.255.255.0 192.168.1.2
Starling#ip route 192.168.3.0 255.255.255.252 192.168.1.2
Starling#ip route 192.168.4.0 255.255.255.0 192.168.1.2
Starling#^Z
Router Idschool
Idschool>enable
Idschool#configure terminal
Idschool#ip route 192.168.0.0 255.255.255.0 192.168.1.1
Idschool#ip route 192.168.4.0 255.255.255.0 192.168.3.2
Idschool#^Z
Router Nusatama
Nusatama>enable
Nusatama#configure terminal
Nusatama#ip route 192.168.0.0 255.255.255.0 192.168.3.1
Nusatama#ip route 192.168.1.0 255.255.255.252 192.168.3.1
Nusatama#ip route 192.168.2.0 255.255.255.0 192.168.3.1
Nusatama#^Z

Untuk melakukan pengujian, lakukan melalui PC0 yang memiliki alamat IP 192.168.0.2, jangan lupa masukan default gateway untuk PC0 ini adalah 192.168.0.1. Kemudian lakukan perintah ping ke alamat IP dari masing-masing router, seharusnya semua router bisa di ping, bila masih ada yang belum bisa coba di check lagi konfigurasi routing statis diatas.

Kekurangan dan kelebihan dari Routing Statis diantaranya sebagai berikut :

Dilihat dari Segi
Kelebihan
Kekurangan
Penggunaan Next Hop
Dapat mencegah terjadinya error dalam meneruskan paket ke router tujuan apabila router yang akan meneruskan paket memiliki link yang terhubung dengan banyak router. Itu disebabkan karena router telah mengetahui next hop, yaitu IP Address router tujuan.
static routing yang menggunakan next hop akan mengalami multiple lookup atau lookup yg berulang. lookup yg pertama yang akan dilakukan adalah mencari network tujuan,setelah itu akan kembali melakukan proses lookup untuk mencari interface mana yang digunakan untuk menjangkau next hopnya.
Penggunaan exit interface
Proses lookup hanya akan terjadi satu kali saja ( single lookup ) karena router akan langsung meneruskan paket ke network tujuan melalui interface yang sesuai pada routing table
Kemungkinan akan terjadi eror keteka meneruskan paket. jika link router terhubung dengan banyak router, maka router tidak bisa memutuskan router mana tujuanya karena tidak adanya next hop pada tabel routing. karena itulah, akan terjadi eror

Routing static dengan menggunakan next hop cocok digunakan untuk jaringan multi-access network atau point to multipoint sedangkan untuk jaringan point to point, cocok dengan menggunakan exit interface dalam mengkonfigurasi static route.

Recursive route lookup adalah proses yang terjadi pada routing tabel untuk menentukan exit interface mana yang akan digunakan ketika akan meneruskan paket ke tujuannya.

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s